summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in11
1 files changed, 8 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index d784b88..55782f0 100644
--- a/configure.in
+++ b/configure.in
@@ -1,4 +1,4 @@
-dnl $Id: configure.in,v 1.18 2001-08-27 03:47:47 rjkaes Exp $
+dnl $Id: configure.in,v 1.19 2001-08-27 17:47:25 rjkaes Exp $
dnl Devlopers, please strive to achieve this order:
dnl
@@ -19,7 +19,7 @@ AC_INIT()
AC_CANONICAL_SYSTEM
AC_DEFINE_UNQUOTED(TARGET_SYSTEM, "$target")
-AM_INIT_AUTOMAKE(tinyproxy,1.4.1.3)
+AM_INIT_AUTOMAKE(tinyproxy,1.4.1.4)
AM_CONFIG_HEADER(config.h)
dnl
@@ -106,7 +106,12 @@ else
if test "$ac_cv_lib_pthreads_pthread_create" = "yes"; then
CFLAGS="-D_REENTRANT $CFLAGS"
else
- AC_MSG_ERROR(You must have a POSIX compliant threading library installed)
+ AC_CHECK_LIB(c_r, pthread_create)
+ if test "$ac_cv_c_r_pthread_create" = "yes"; then
+ CFLAGS="-pthread -D_REENTRANT $CFLAGS"
+ else
+ AC_MSG_ERROR(You must have a POSIX compliant threading library installed)
+ fi
fi
fi