summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am33
1 files changed, 20 insertions, 13 deletions
diff --git a/Makefile.am b/Makefile.am
index 460f952..065df86 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -2,16 +2,23 @@ EXTRA_DIST = TODO
SUBDIRS = src doc
install-data-local:
- mkdir -p @TINYPROXY_CONFIG_DIR@
- $(INSTALL) doc/tinyproxy.conf @TINYPROXY_CONFIG@-dist
- test ! -f @TINYPROXY_CONFIG@ && $(INSTALL) doc/tinyproxy.conf @TINYPROXY_CONFIG@
- echo ""
- echo "A configuration file has been copied to:"
- echo "@TINYPROXY_CONFIG@-dist"
- echo "You will need to rename this file to:"
- echo "@TINYPROXY_CONFIG@"
- echo "and modify the values to suit your local system."
- echo ""
- echo "All the configuration directives are commented in the file, so"
- echo "you should not have any problems configuring your system."
- echo "" \ No newline at end of file
+ $(mkinstalldirs) $(DESTDIR)@TINYPROXY_CONFIG_DIR@
+ $(INSTALL) -m 600 doc/tinyproxy.conf \
+ $(DESTDIR)@TINYPROXY_CONFIG_DIR@/@TINYPROXY_CONFIG_FILE@-dist
+ test ! -f $(DESTDIR)@TINYPROXY_CONFIG_DIR@/@TINYPROXY_CONFIG_FILE@ \
+ && $(INSTALL) -m 600 doc/tinyproxy.conf \
+ $(DESTDIR)@TINYPROXY_CONFIG_DIR@/@TINYPROXY_CONFIG_FILE@
+ @echo ""
+ @echo "A configuration file has been copied to:"
+ @echo ""
+ @echo "@TINYPROXY_CONFIG_DIR@/@TINYPROXY_CONFIG_FILE@-dist"
+ @echo ""
+ @echo "You will need to rename this file to:"
+ @echo ""
+ @echo "@TINYPROXY_CONFIG_DIR@/@TINYPROXY_CONFIG_FILE@"
+ @echo ""
+ @echo "and modify the values to suit your local system."
+ @echo ""
+ @echo "All the configuration directives are commented in the file, so"
+ @echo "you should not have any problems configuring your system."
+ @echo "" \ No newline at end of file