summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorRobert James Kaes <rjkaes@users.sourceforge.net>2001-11-23 16:56:59 +0000
committerRobert James Kaes <rjkaes@users.sourceforge.net>2001-11-23 16:56:59 +0000
commitaf53747181591e93a982e2cd1c734f9cac6df7af (patch)
tree0e36cf20674770d522499570a5c42e88e9e863e4 /configure.in
parent4aa5e79cdf2435d9b53898130e63811e3a2a013c (diff)
downloadtinyproxy-af53747181591e93a982e2cd1c734f9cac6df7af.tar.gz
tinyproxy-af53747181591e93a982e2cd1c734f9cac6df7af.zip
Fixed a problem with testing numbers using the x"$string" format.
Added a default case for libnsl ("no" if not found.)
Diffstat (limited to '')
-rw-r--r--configure.in10
1 files changed, 6 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index dee6d71..abc329c 100644
--- a/configure.in
+++ b/configure.in
@@ -1,4 +1,4 @@
-dnl $Id: configure.in,v 1.36 2001-11-23 01:15:01 rjkaes Exp $
+dnl $Id: configure.in,v 1.37 2001-11-23 16:56:59 rjkaes Exp $
dnl Devlopers, please strive to achieve this order:
dnl
@@ -126,7 +126,7 @@ else
oldIFS=$IFS; IFS=.
set `bison -V | sed -e 's/^GNU Bison version //'`
IFS=$oldIFS
- if test x"$1" = x"1" -a x"$2" -lt x"25"; then
+ if test x"$1" = x"1" -a "$2" -lt "25"; then
AC_MSG_WARN(Bison 1.25 or newer needed to regenerate parsers (found $1.$2).)
fi
AC_MSG_RESULT($1.$2 (ok))
@@ -159,7 +159,9 @@ dnl avoid -lnsl checks, if we already have the functions which are
dnl usually in libnsl
unset ac_cv_func_yp_get_default_domain
-AC_CHECK_FUNC(yp_get_default_domain, [ tinyproxy_no_nsl_checks=yes ], [ ])
+AC_CHECK_FUNC(yp_get_default_domain,
+ [ tinyproxy_no_nsl_checks=yes ],
+ [ tinyproxy_no_nsl_checks=no ])
unset ac_cv_func_yp_get_default_domain
if test x"$tinyproxy_no_nsl_checks" != x"yes"; then
@@ -348,4 +350,4 @@ AC_SUBST(CPPFLAGS)
AC_SUBST(LIBS)
AC_SUBST(LIBOBJS)
-AC_OUTPUT(Makefile src/Makefile doc/Makefile) \ No newline at end of file
+AC_OUTPUT(Makefile src/Makefile doc/Makefile)