summaryrefslogtreecommitdiff
path: root/docs/man5/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'docs/man5/Makefile.am')
-rw-r--r--docs/man5/Makefile.am23
1 files changed, 23 insertions, 0 deletions
diff --git a/docs/man5/Makefile.am b/docs/man5/Makefile.am
new file mode 100644
index 0000000..340e127
--- /dev/null
+++ b/docs/man5/Makefile.am
@@ -0,0 +1,23 @@
+MAN5_FILES = \
+ tinyproxy.conf.txt
+
+A2X_ARGS = \
+ -d manpage \
+ -f manpage
+
+man_MANS = \
+ $(MAN5_FILES:.txt=.5)
+
+.txt.5:
+if HAVE_A2X
+ a2x $(A2X_ARGS) $<
+else
+ @echo "*** a2x (asciidoc) is required to regenerate $(@) ***"; exit 1;
+endif
+
+EXTRA_DIST = \
+ $(man_MANS)
+
+CLEANFILES = \
+ $(MAN5_FILES:.txt=.5) \
+ $(MAN5_FILES:.txt=.xml)