summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--configure.in8
1 files changed, 4 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index ee3a090..1c095d4 100644
--- a/configure.in
+++ b/configure.in
@@ -1,7 +1,7 @@
-dnl $Id: configure.in,v 1.6 2001-01-15 17:13:37 rjkaes Exp $
+dnl $Id: configure.in,v 1.7 2001-05-27 02:40:23 rjkaes Exp $
AC_INIT()
-AM_INIT_AUTOMAKE(tinyproxy,1.4.0pre2)
+AM_INIT_AUTOMAKE(tinyproxy,1.4.0pre3)
AM_CONFIG_HEADER(config.h)
AC_CANONICAL_HOST
@@ -17,7 +17,7 @@ AM_C_PROTOTYPES
dnl Checks for header files.
AC_HEADER_STDC
-AC_CHECK_HEADERS(sys/types.h sys/socket.h sys/time.h time.h netinet/in.h arpa/inet.h error.h fcntl.h netdb.h signal.h stdio.h stdint.h stdlib.h string.h sys/stat.h sys/uio.h unistd.h sys/wait.h sys/un.h sys/select.h strings.h sys/ioctl.h pthread.h sys/sysctl.h syslog.h stdint.h)
+AC_CHECK_HEADERS(sys/types.h sys/socket.h sys/time.h time.h netinet/in.h arpa/inet.h error.h fcntl.h netdb.h signal.h stdio.h stdint.h stdlib.h string.h sys/stat.h sys/uio.h unistd.h sys/wait.h sys/un.h sys/select.h strings.h sys/ioctl.h pthread.h sys/sysctl.h syslog.h stdint.h sys/resource.h)
dnl Checks for typedefs, structures, and compiler characteristics.
AC_C_CONST
@@ -53,7 +53,7 @@ dnl Checks for library functions.
AC_TYPE_SIGNAL
AC_FUNC_STRFTIME
AC_FUNC_VPRINTF
-AC_CHECK_FUNCS(socket select strerror strdup vsyslog vsnprintf)
+AC_CHECK_FUNCS(ftruncate select setrlimit socket strdup strerror vsnprintf vsyslog)
AC_CHECK_FUNCS(strlcpy strlcat)
dnl chris - allow user to choose log file location, port and username