summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac35
1 files changed, 20 insertions, 15 deletions
diff --git a/configure.ac b/configure.ac
index 93f1e45..47ef080 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,4 +1,4 @@
-dnl $Id: configure.ac,v 2.37 2002-06-05 17:06:05 rjkaes Exp $
+dnl $Id: configure.ac,v 2.38 2002-06-06 20:27:01 rjkaes Exp $
dnl Devlopers, please strive to achieve this order:
dnl
@@ -95,19 +95,20 @@ AC_ARG_ENABLE(socks,
socks_enabled=$enableval, socks_enabled=no)
dnl Check to see if the XTinyproxy header is to be included
+AH_TEMPLATE([XTINYPROXY_ENABLE],
+ [Define if you want to have the peer's IP address included in a XTinyproxy header sent to the server.])
AC_ARG_ENABLE(xtinyproxy,
[AC_HELP_STRING([--enable-xtinyproxy],
[Include X-Tinyproxy header (default is YES)])],
xtinyproxy_enabled=$enableval, xtinyproxy_enabled=yes)
if test x"$xtinyproxy_enabled" = x"yes"; then
- AH_TEMPLATE([XTINYPROXY_ENABLE],
- [Define if you want to have the peer's IP address included in
- a XTinyproxy header sent to the server.])
AC_DEFINE(XTINYPROXY_ENABLE)
fi
dnl Include filtering for domain/URLs
+AH_TEMPLATE([FILTER_ENABLE],
+ [Defined if you would like filtering code included.])
AC_ARG_ENABLE(filter,
[AC_HELP_STRING([--enable-filter],
[Enable filtering of domains/URLs (default is YES)])],
@@ -115,37 +116,41 @@ AC_ARG_ENABLE(filter,
if test x"$filter_enabled" = x"yes"; then
ADDITIONAL_OBJECTS="$ADDITIONAL_OBJECTS filter.o"
-
- AH_TEMPLATE([FILTER_ENABLE],
- [Defined if you would like filtering code included.])
-
AC_DEFINE(FILTER_ENABLE)
fi
dnl Include support for TCP tunneling
+AH_TEMPLATE([TUNNEL_SUPPORT], [Include TCP tunnelling support])
AC_ARG_ENABLE(tunnel,
[AC_HELP_STRING([--enable-tunnel],
[Enable support for TCP tunneling (default is YES)])],
tunnel_enabled=$enableval, tunnel_enabled=yes)
-if test x"$tunnel_enabled" = x"yes" ; then
- AH_TEMPLATE([TUNNEL_SUPPORT],
- [Include TCP tunnelling support?])
-
+if test x"$tunnel_enabled" = x"yes"; then
AC_DEFINE(TUNNEL_SUPPORT)
fi
dnl Include support for upstream proxies?
+AH_TEMPLATE([UPSTREAM_SUPPORT],
+ [Include support for connecting to an upstream proxy.])
AC_ARG_ENABLE(upstream,
[AC_HELP_STRING([--enable-upstream],
[Enable support for upstream proxies (default is YES)])],
upstream_enabled=$enableval, upstream_enabled=yes)
if test x"$upstream_enabled" = x"yes"; then
- AH_TEMPLATE([UPSTREAM_SUPPORT],
- [Include support for connecting to an upstream proxy.])
-
AC_DEFINE(UPSTREAM_SUPPORT)
fi
+dnl Include the transparent proxy support
+AH_TEMPLATE([TRANSPARENT_PROXY],
+ [Include support for using tinyproxy as a transparent proxy.])
+AC_ARG_ENABLE(transparent-proxy,
+ [AC_HELP_STRING([--enable-transparent-proxy],
+ [Enable transparent proxy support (default is NO)])],
+ transparent_enabled=$enableval, transparent_enabled=no)
+if test x"$transparent_enabled" = x"yes"; then
+ AC_DEFINE(TRANSPARENT_PROXY)
+fi
+
dnl Include support for a statically compiled tinyproxy
AC_ARG_ENABLE(static,
[AC_HELP_STRING([--enable-static],