summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am17
1 files changed, 17 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 7de41f2..d97429c 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -9,6 +9,23 @@ SUBDIRS = \
# tools want this on a single line
ACLOCAL_AMFLAGS = -I m4macros
+AUTHORS: authors.xml authors.xsl
+if HAVE_XSLTPROC
+ $(AM_V_GEN) $(XSLTPROC) authors.xsl $< > $(@) || rm -f $(@)
+else
+ @echo "*** xsltproc is required to regenerate $(@) ***"; exit 1;
+endif
+
+validate-authors:
+if HAVE_XMLLINT
+ @$(XMLLINT) --noout --path $(srcdir) --valid authors.xml || \
+ ( echo "*** authors.xml IS INVALID ***"; exit 1; )
+endif
+
+all-local: AUTHORS
+
+check-local: validate-authors
+
EXTRA_DIST = \
autogen.sh \
tinyproxy-indent.sh \