summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorRobert James Kaes <rjkaes@users.sourceforge.net>2001-11-05 15:25:39 +0000
committerRobert James Kaes <rjkaes@users.sourceforge.net>2001-11-05 15:25:39 +0000
commit99488cbd5e6d1719363a8edc47ca62f1fce82583 (patch)
tree9585238f3886cb3b82c11c37cef2374a1907b7f9 /configure.in
parentfffdc76681b5d44e3d8134b0be78334ee5f3a2b1 (diff)
downloadtinyproxy-99488cbd5e6d1719363a8edc47ca62f1fce82583.tar.gz
tinyproxy-99488cbd5e6d1719363a8edc47ca62f1fce82583.zip
Added profiling flags to the DEBUG version of CFLAGS.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index fc2257c..8e838e0 100644
--- a/configure.in
+++ b/configure.in
@@ -1,4 +1,4 @@
-dnl $Id: configure.in,v 1.33 2001-10-25 05:13:46 rjkaes Exp $
+dnl $Id: configure.in,v 1.34 2001-11-05 15:25:39 rjkaes Exp $
dnl Devlopers, please strive to achieve this order:
dnl
@@ -253,6 +253,7 @@ CFLAGS="-O2 $CFLAGS"
if test "$enable_debug" = "yes" ; then
dnl Add the warnings if we have the GCC compiler
if test "$ac_cv_prog_gcc" = "yes" ; then
+ CFLAGS="-pg -fprofile-arcs $CFLAGS"
CFLAGS="-Wshadow -Wcast-qual -Wcast-align -Wstrict-prototypes $CFLAGS"
CFLAGS="-Wmissing-prototypes -Wmissing-declarations $CFLAGS"
CFLAGS="-Wpointer-arith -Waggregate-return -Wnested-externs $CFLAGS"