summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorRobert James Kaes <rjkaes@users.sourceforge.net>2001-09-16 20:07:24 +0000
committerRobert James Kaes <rjkaes@users.sourceforge.net>2001-09-16 20:07:24 +0000
commit4e2b0d5b83b995d8f673ad3a5e0f96370c3badb4 (patch)
treec0bb85aed423754e361f98383062d2c22cd5de5f /configure.in
parent319a1c65b153817a9331b0ecd1cc1469ec2a13e4 (diff)
downloadtinyproxy-4e2b0d5b83b995d8f673ad3a5e0f96370c3badb4.tar.gz
tinyproxy-4e2b0d5b83b995d8f673ad3a5e0f96370c3badb4.zip
Added a configure option for upstream proxy support.
Bumped the version number.
Diffstat (limited to '')
-rw-r--r--configure.in14
1 files changed, 11 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index 5a630a9..4de43e1 100644
--- a/configure.in
+++ b/configure.in
@@ -1,4 +1,4 @@
-dnl $Id: configure.in,v 1.29 2001-09-14 23:44:47 rjkaes Exp $
+dnl $Id: configure.in,v 1.30 2001-09-16 20:07:24 rjkaes Exp $
dnl Devlopers, please strive to achieve this order:
dnl
@@ -19,7 +19,7 @@ AC_INIT()
AC_CANONICAL_SYSTEM
AC_DEFINE_UNQUOTED(TARGET_SYSTEM, "$target")
-AM_INIT_AUTOMAKE(tinyproxy,1.4.3pre4)
+AM_INIT_AUTOMAKE(tinyproxy,1.4.3pre5)
AM_CONFIG_HEADER(config.h)
dnl
@@ -62,7 +62,7 @@ if test "$filter_enabled" = "yes"; then
AC_DEFINE(FILTER_ENABLE)
fi
-dnl Include support for upstream proxies? (TCP tunneling)
+dnl Include support for TCP tunneling
AC_ARG_ENABLE(tunnel,
[ --enable-tunnel Enable support for TCP tunneling [default=yes]],
tunnel_enabled=yes, tunnel_enabled=yes)
@@ -70,6 +70,14 @@ if test "$tunnel_enabled" = "yes" ; then
AC_DEFINE(TUNNEL_SUPPORT)
fi
+dnl Include support for upstream proxies?
+AC_ARG_ENABLE(upstream,
+[ --enable-upstream Enable support for upstream proxies [default=yes]],
+ upstream_enabled=yes, upstream_enabled=yes)
+if test "$upstream_enabled" = "yes"; then
+ AC_DEFINE(UPSTREAM_SUPPORT)
+fi
+
dnl
dnl Checks for programs
dnl