summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRobert James Kaes <rjkaes@users.sourceforge.net>2002-04-09 20:04:05 +0000
committerRobert James Kaes <rjkaes@users.sourceforge.net>2002-04-09 20:04:05 +0000
commit607e4c4c6cd00ca6c164251f9649d9d87d96d05d (patch)
tree83fbc59041c6877bc5ec01905df2b1c880dfc199 /configure.ac
parent3c631c6e5c2cfb77b76f933c91385c8fb2a1ad17 (diff)
downloadtinyproxy-607e4c4c6cd00ca6c164251f9649d9d87d96d05d.tar.gz
tinyproxy-607e4c4c6cd00ca6c164251f9649d9d87d96d05d.zip
Fixed up the problem with the "-lc_r" inclusion code.
_Really_ fixed up the problem with compiling under OpenBSD. Bumped up the version number.
Diffstat (limited to '')
-rw-r--r--configure.ac17
1 files changed, 7 insertions, 10 deletions
diff --git a/configure.ac b/configure.ac
index cffabf8..121045b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,4 +1,4 @@
-dnl $Id: configure.ac,v 2.10 2002-04-09 16:32:39 rjkaes Exp $
+dnl $Id: configure.ac,v 2.11 2002-04-09 20:04:05 rjkaes Exp $
dnl Devlopers, please strive to achieve this order:
dnl
@@ -14,7 +14,7 @@ dnl 8. System services
dnl
dnl Read the Autoconf manual for details.
-AC_INIT([tinyproxy], [1.5.0pre2], [rjkaes@users.sourceforge.net])
+AC_INIT([tinyproxy], [1.5.0pre3], [rjkaes@users.sourceforge.net])
AC_CONFIG_SRCDIR([src/tinyproxy.c])
AC_PREREQ(2.52)
@@ -180,13 +180,10 @@ else
else
AC_MSG_ERROR([You must have a POSIX compliant threading library installed])
fi
- case "$target" in
- *-freebsd*)
- ;;
- *)
- LIBS = "$LIBS -lc_r"
- ;;
- esac
+ case "$target" in
+ *-freebsd*) ;;
+ *) LIBS="$LIBS -lc_r";;
+ esac
fi
fi
@@ -225,7 +222,7 @@ AC_CHECK_HEADERS([sys/types.h sys/ioctl.h sys/resource.h sys/select.h \
dnl OpenBSD machines don't like having malloc included (even if it's present)
dnl as they expect you to use stdlib.h
case "$target" in
- *openbsd*) ;;
+ *-openbsd*) ;;
*) AC_CHECK_HEADER(malloc.h);;
esac