summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt550
1 files changed, 550 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 0000000..3c50f92
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,550 @@
+cmake_minimum_required(VERSION 3.25)
+project(t2win)
+
+set(CMAKE_CXX_STANDARD 14)
+
+include_directories(SYSTEM "/Users/ash/.wine/drive_c/Program Files (x86)/DevStudio/VC/include")
+include_directories(SYSTEM "/Users/ash/.wine/drive_c/Program Files (x86)/DevStudio/VC/mfc/include")
+include_directories(SYSTEM "/Users/ash/src/t2-res/dx5/cdrom/sdk/inc")
+include_directories(SYSTEM "/Users/ash/src/t2-res/dxmedia51/DX51/dxmdev/include")
+include_directories(src)
+include_directories(src/T2DLL)
+
+add_executable(t2win
+ src/T2DLL/CDefRsrcPlugin.cpp
+ src/T2DLL/CDefRsrcPlugin.h
+ src/T2DLL/CFilePlugin.cpp
+ src/T2DLL/CFilePlugin.h
+ src/T2DLL/CFilePluginDB.cpp
+ src/T2DLL/CFilePluginDB.h
+ src/T2DLL/CFilePluginList.cpp
+ src/T2DLL/CFilePluginList.h
+ src/T2DLL/CLink.cpp
+ src/T2DLL/CLink.h
+ src/T2DLL/CObjectList.cpp
+ src/T2DLL/CObjectList.h
+ src/T2DLL/CObjectQueue.cpp
+ src/T2DLL/CObjectQueue.h
+ src/T2DLL/CPEFile.cpp
+ src/T2DLL/CPEFile.h
+ src/T2DLL/CPieChartView.cpp
+ src/T2DLL/CPieChartView.h
+ src/T2DLL/CPiledMultiBarChartView.cpp
+ src/T2DLL/CPiledMultiBarChartView.h
+ src/T2DLL/CPlugin.cpp
+ src/T2DLL/CPlugin.h
+ src/T2DLL/CPluginInfo.cpp
+ src/T2DLL/CPluginInfo.h
+ src/T2DLL/CPluginInfoArray.cpp
+ src/T2DLL/CPluginInfoArray.h
+ src/T2DLL/CPluginInfoComparator.cpp
+ src/T2DLL/CPluginInfoComparator.h
+ src/T2DLL/CProgramPlugin.cpp
+ src/T2DLL/CProgramPlugin.h
+ src/T2DLL/CResFile.cpp
+ src/T2DLL/CResFile.h
+ src/T2DLL/CResourcePlugin.cpp
+ src/T2DLL/CResourcePlugin.h
+ src/T2DLL/CToggleButtonDisabled.cpp
+ src/T2DLL/CToggleButtonDisabled.h
+ src/T2DLL/CTokenizer.cpp
+ src/T2DLL/CTokenizer.h
+ src/T2DLL/GlobalFunc.cpp
+ src/T2DLL/GlobalFunc.h
+ src/T2DLL/LArray.cpp
+ src/T2DLL/LArray.h
+ src/T2DLL/LAttachable.cpp
+ src/T2DLL/LAttachable.h
+ src/T2DLL/LAttachment.cpp
+ src/T2DLL/LAttachment.h
+ src/T2DLL/LBroadcaster.cpp
+ src/T2DLL/LBroadcaster.h
+ src/T2DLL/LComparator.cpp
+ src/T2DLL/LComparator.h
+ src/T2DLL/LListener.cpp
+ src/T2DLL/LListener.h
+ src/T2DLL/LPeriodical.cpp
+ src/T2DLL/LPeriodical.h
+ src/T2DLL/Mmio.cpp
+ src/T2DLL/MMIO.h
+ src/T2DLL/T2AdvertisePlugin.cpp
+ src/T2DLL/T2AdvertisePlugin.h
+ src/T2DLL/T2AdvertiseTable.cpp
+ src/T2DLL/T2AdvertiseTable.h
+ src/T2DLL/T2Animation.cpp
+ src/T2DLL/T2Animation.h
+ src/T2DLL/T2Archive.cpp
+ src/T2DLL/T2Archive.h
+ src/T2DLL/T2ArrowWnd.cpp
+ src/T2DLL/T2ArrowWnd.h
+ src/T2DLL/T2Balloon.cpp
+ src/T2DLL/T2Balloon.h
+ src/T2DLL/T2BalloonWnd.cpp
+ src/T2DLL/T2BalloonWnd.h
+ src/T2DLL/T2BitImage.cpp
+ src/T2DLL/T2BitImage.h
+ src/T2DLL/T2BlackOut.cpp
+ src/T2DLL/T2BlackOut.h
+ src/T2DLL/T2ClassFactory.cpp
+ src/T2DLL/T2ClassFactory.h
+ src/T2DLL/T2CrossEquipArray.cpp
+ src/T2DLL/T2CrossEquipArray.h
+ src/T2DLL/T2CustomerTableIterator.cpp
+ src/T2DLL/T2CustomerTableIterator.h
+ src/T2DLL/T2DateTime.cpp
+ src/T2DLL/T2DateTime.h
+ src/T2DLL/T2DayLightFilter.cpp
+ src/T2DLL/T2DayLightFilter.h
+ src/T2DLL/T2DayParamDef.cpp
+ src/T2DLL/T2DayParamDef.h
+ src/T2DLL/T2Dialog.cpp
+ src/T2DLL/T2Dialog.h
+ src/T2DLL/T2DlgItem.cpp
+ src/T2DLL/T2DlgItem.h
+ src/T2DLL/T2DlgItemAllPurpose.cpp
+ src/T2DLL/T2DlgItemAllPurpose.h
+ src/T2DLL/T2DlgItemAnimation.cpp
+ src/T2DLL/T2DlgItemAnimation.h
+ src/T2DLL/T2DlgItemAPTable.cpp
+ src/T2DLL/T2DlgItemAPTable.h
+ src/T2DLL/T2DlgItemBelongGage.cpp
+ src/T2DLL/T2DlgItemBelongGage.h
+ src/T2DLL/T2DlgItemBox.cpp
+ src/T2DLL/T2DlgItemBox.h
+ src/T2DLL/T2DlgItemButtonBase.cpp
+ src/T2DLL/T2DlgItemButtonBase.h
+ src/T2DLL/T2DlgItemCANCEL.cpp
+ src/T2DLL/T2DlgItemCANCEL.h
+ src/T2DLL/T2DlgItemCheck.cpp
+ src/T2DLL/T2DlgItemCheck.h
+ src/T2DLL/T2DlgItemCustomerGage.cpp
+ src/T2DLL/T2DlgItemCustomerGage.h
+ src/T2DLL/T2DlgItemEdit.cpp
+ src/T2DLL/T2DlgItemEdit.h
+ src/T2DLL/T2DlgItemGageBase.cpp
+ src/T2DLL/T2DlgItemGageBase.h
+ src/T2DLL/T2DlgItemHScr.cpp
+ src/T2DLL/T2DlgItemHScr.h
+ src/T2DLL/T2DlgItemIButton.cpp
+ src/T2DLL/T2DlgItemIButton.h
+ src/T2DLL/T2DlgItemICheck.cpp
+ src/T2DLL/T2DlgItemICheck.h
+ src/T2DLL/T2DlgItemImage.cpp
+ src/T2DLL/T2DlgItemImage.h
+ src/T2DLL/T2DlgItemImageTable.cpp
+ src/T2DLL/T2DlgItemImageTable.h
+ src/T2DLL/T2DlgItemListBox.cpp
+ src/T2DLL/T2DlgItemListBox.h
+ src/T2DLL/T2DlgItemMovie.cpp
+ src/T2DLL/T2DlgItemMovie.h
+ src/T2DLL/T2DlgItemOK.cpp
+ src/T2DLL/T2DlgItemOK.h
+ src/T2DLL/T2DlgItemPeopleView.cpp
+ src/T2DLL/T2DlgItemPeopleView.h
+ src/T2DLL/T2DlgItemPopup.cpp
+ src/T2DLL/T2DlgItemPopup.h
+ src/T2DLL/T2DlgItemPPLEvalGage.cpp
+ src/T2DLL/T2DlgItemPPLEvalGage.h
+ src/T2DLL/T2DlgItemProfitsGage.cpp
+ src/T2DLL/T2DlgItemProfitsGage.h
+ src/T2DLL/T2DlgItemProgress.cpp
+ src/T2DLL/T2DlgItemProgress.h
+ src/T2DLL/T2DlgItemScr.cpp
+ src/T2DLL/T2DlgItemScr.h
+ src/T2DLL/T2DlgItemSTimeTbl.cpp
+ src/T2DLL/T2DlgItemSTimeTbl.h
+ src/T2DLL/T2DlgItemStressGage.cpp
+ src/T2DLL/T2DlgItemStressGage.h
+ src/T2DLL/T2DlgItemTab.cpp
+ src/T2DLL/T2DlgItemTab.h
+ src/T2DLL/T2DlgItemTable.cpp
+ src/T2DLL/T2DlgItemTable.h
+ src/T2DLL/T2DlgItemTButton.cpp
+ src/T2DLL/T2DlgItemTButton.h
+ src/T2DLL/T2DlgItemText.cpp
+ src/T2DLL/T2DlgItemText.h
+ src/T2DLL/T2DlgItemVScr.cpp
+ src/T2DLL/T2DlgItemVScr.h
+ src/T2DLL/T2DrawableObject.cpp
+ src/T2DLL/T2DrawableObject.h
+ src/T2DLL/T2ElevatorModule.cpp
+ src/T2DLL/T2ElevatorModule.h
+ src/T2DLL/T2ElvModuleList.cpp
+ src/T2DLL/T2ElvModuleList.h
+ src/T2DLL/T2Equip.cpp
+ src/T2DLL/T2Equip.h
+ src/T2DLL/T2EquipDef.cpp
+ src/T2DLL/T2EquipDef.h
+ src/T2DLL/T2EquipInfoDialog.cpp
+ src/T2DLL/T2EquipInfoDialog.h
+ src/T2DLL/T2EquipPlugin.cpp
+ src/T2DLL/T2EquipPlugin.h
+ src/T2DLL/T2EquipPtrList.cpp
+ src/T2DLL/T2EquipPtrList.h
+ src/T2DLL/T2EventItem.cpp
+ src/T2DLL/T2EventItem.h
+ src/T2DLL/T2FInfoAreaIterator.cpp
+ src/T2DLL/T2FInfoAreaIterator.h
+ src/T2DLL/T2FireBurning.cpp
+ src/T2DLL/T2FireBurning.h
+ src/T2DLL/T2FireWork.cpp
+ src/T2DLL/T2FireWork.h
+ src/T2DLL/T2FloorCEArray.cpp
+ src/T2DLL/T2FloorCEArray.h
+ src/T2DLL/T2FloorInfo.cpp
+ src/T2DLL/T2FloorInfo.h
+ src/T2DLL/T2FloorNumberTable.cpp
+ src/T2DLL/T2FloorNumberTable.h
+ src/T2DLL/T2FloorPtrList.cpp
+ src/T2DLL/T2FloorPtrList.h
+ src/T2DLL/T2GlobalData.cpp
+ src/T2DLL/T2GlobalData.h
+ src/T2DLL/T2GuestroomTable.cpp
+ src/T2DLL/T2GuestroomTable.h
+ src/T2DLL/T2HallEventPlugin.cpp
+ src/T2DLL/T2HallEventPlugin.h
+ src/T2DLL/T2HallEventTable.cpp
+ src/T2DLL/T2HallEventTable.h
+ src/T2DLL/T2HaveOutViewObject.cpp
+ src/T2DLL/T2HaveOutViewObject.h
+ src/T2DLL/T2ImageObj.cpp
+ src/T2DLL/T2ImageObj.h
+ src/T2DLL/T2InfoDialog.cpp
+ src/T2DLL/T2InfoDialog.h
+ src/T2DLL/T2Maru_Reggae.cpp
+ src/T2DLL/T2Maru_Reggae.h
+ src/T2DLL/T2Matter.cpp
+ src/T2DLL/T2Matter.h
+ src/T2DLL/T2MatterArray.cpp
+ src/T2DLL/T2MatterArray.h
+ src/T2DLL/T2MatterArrayList.cpp
+ src/T2DLL/T2MatterArrayList.h
+ src/T2DLL/T2MatterDef.cpp
+ src/T2DLL/T2MatterDef.h
+ src/T2DLL/T2Message.cpp
+ src/T2DLL/T2Message.h
+ src/T2DLL/T2Mover.cpp
+ src/T2DLL/T2Mover.h
+ src/T2DLL/T2MoverArray.cpp
+ src/T2DLL/T2MoverArray.h
+ src/T2DLL/T2MoverArrayList.cpp
+ src/T2DLL/T2MoverArrayList.h
+ src/T2DLL/T2MoverCEArray.cpp
+ src/T2DLL/T2MoverCEArray.h
+ src/T2DLL/T2MoverDef.cpp
+ src/T2DLL/T2MoverDef.h
+ src/T2DLL/T2MoverModule.cpp
+ src/T2DLL/T2MoverModule.h
+ src/T2DLL/T2MoverModuleList.cpp
+ src/T2DLL/T2MoverModuleList.h
+ src/T2DLL/T2MoverModuleTable.cpp
+ src/T2DLL/T2MoverModuleTable.h
+ src/T2DLL/T2MoverPlugin.cpp
+ src/T2DLL/T2MoverPlugin.h
+ src/T2DLL/T2MoverRoutingTable.cpp
+ src/T2DLL/T2MoverRoutingTable.h
+ src/T2DLL/T2MovieParamArray.cpp
+ src/T2DLL/T2MovieParamArray.h
+ src/T2DLL/T2MoviePlugin.cpp
+ src/T2DLL/T2MoviePlugin.h
+ src/T2DLL/T2MoviePluginList.cpp
+ src/T2DLL/T2MoviePluginList.h
+ src/T2DLL/T2MovieTable.cpp
+ src/T2DLL/T2MovieTable.h
+ src/T2DLL/T2MsgWindowCallback.cpp
+ src/T2DLL/T2MsgWindowCallback.h
+ src/T2DLL/T2Name.cpp
+ src/T2DLL/T2Name.h
+ src/T2DLL/T2NameList.cpp
+ src/T2DLL/T2NameList.h
+ src/T2DLL/T2NameTable.cpp
+ src/T2DLL/T2NameTable.h
+ src/T2DLL/T2Object.cpp
+ src/T2DLL/T2Object.h
+ src/T2DLL/T2ObjectArray.cpp
+ src/T2DLL/T2ObjectArray.h
+ src/T2DLL/T2ObjectArrayList.cpp
+ src/T2DLL/T2ObjectArrayList.h
+ src/T2DLL/T2OptionPluginList.cpp
+ src/T2DLL/T2OptionPluginList.h
+ src/T2DLL/T2OutDecoration.cpp
+ src/T2DLL/T2OutDecoration.h
+ src/T2DLL/T2OuterObjDef.cpp
+ src/T2DLL/T2OuterObjDef.h
+ src/T2DLL/T2OuterObjList.cpp
+ src/T2DLL/T2OuterObjList.h
+ src/T2DLL/T2OuterObjPlugin.cpp
+ src/T2DLL/T2OuterObjPlugin.h
+ src/T2DLL/T2OutObj.cpp
+ src/T2DLL/T2OutObj.h
+ src/T2DLL/T2OutObjArray.cpp
+ src/T2DLL/T2OutObjArray.h
+ src/T2DLL/T2OutObjArrayList.cpp
+ src/T2DLL/T2OutObjArrayList.h
+ src/T2DLL/T2OutObjInfoDialog.cpp
+ src/T2DLL/T2OutObjInfoDialog.h
+ src/T2DLL/T2OutsideInfo.cpp
+ src/T2DLL/T2OutsideInfo.h
+ src/T2DLL/T2PaletteAnime.cpp
+ src/T2DLL/T2PaletteAnime.h
+ src/T2DLL/T2PaletteAnimeDef.cpp
+ src/T2DLL/T2PaletteAnimeDef.h
+ src/T2DLL/T2People.cpp
+ src/T2DLL/T2People.h
+ src/T2DLL/T2PeopleAnimeDef.cpp
+ src/T2DLL/T2PeopleAnimeDef.h
+ src/T2DLL/T2PeopleArray.cpp
+ src/T2DLL/T2PeopleArray.h
+ src/T2DLL/T2PeopleArrayList.cpp
+ src/T2DLL/T2PeopleArrayList.h
+ src/T2DLL/T2PeopleDef.cpp
+ src/T2DLL/T2PeopleDef.h
+ src/T2DLL/T2PeopleDemandList.cpp
+ src/T2DLL/T2PeopleDemandList.h
+ src/T2DLL/T2PeopleInfoDialog.cpp
+ src/T2DLL/T2PeopleInfoDialog.h
+ src/T2DLL/T2PeopleLinkIterator.cpp
+ src/T2DLL/T2PeopleLinkIterator.h
+ src/T2DLL/T2PeopleLoader.cpp
+ src/T2DLL/T2PeopleLoader.h
+ src/T2DLL/T2PeoplePtrList.cpp
+ src/T2DLL/T2PeoplePtrList.h
+ src/T2DLL/T2PeopleTimeZoneList.cpp
+ src/T2DLL/T2PeopleTimeZoneList.h
+ src/T2DLL/T2PeopleType.cpp
+ src/T2DLL/T2PeopleType.h
+ src/T2DLL/T2PeopleTypeArray.cpp
+ src/T2DLL/T2PeopleTypeArray.h
+ src/T2DLL/T2PlaceParamDef.cpp
+ src/T2DLL/T2PlaceParamDef.h
+ src/T2DLL/T2PluginInfoTable.cpp
+ src/T2DLL/T2PluginInfoTable.h
+ src/T2DLL/T2PluginLoader.cpp
+ src/T2DLL/T2PluginLoader.h
+ src/T2DLL/T2PluginSpecifier.cpp
+ src/T2DLL/T2PluginSpecifier.h
+ src/T2DLL/T2Pool.cpp
+ src/T2DLL/T2Pool.h
+ src/T2DLL/T2PoolDef.cpp
+ src/T2DLL/T2PoolDef.h
+ src/T2DLL/T2PrefDialogBox.cpp
+ src/T2DLL/T2PrefDialogBox.h
+ src/T2DLL/T2PrefFile.cpp
+ src/T2DLL/T2PrefFile.h
+ src/T2DLL/T2RegistedTenantDB.cpp
+ src/T2DLL/T2RegistedTenantDB.h
+ src/T2DLL/T2RegistedTenantIterator.cpp
+ src/T2DLL/T2RegistedTenantIterator.h
+ src/T2DLL/T2RemoveFavoriteDialog.cpp
+ src/T2DLL/T2RemoveFavoriteDialog.h
+ src/T2DLL/T2Request.cpp
+ src/T2DLL/T2Request.h
+ src/T2DLL/T2RequestArray.cpp
+ src/T2DLL/T2RequestArray.h
+ src/T2DLL/T2RequestArrayList.cpp
+ src/T2DLL/T2RequestArrayList.h
+ src/T2DLL/T2RequestIDArray.cpp
+ src/T2DLL/T2RequestIDArray.h
+ src/T2DLL/T2ReturnStack.cpp
+ src/T2DLL/T2ReturnStack.h
+ src/T2DLL/T2RouteCEArray.cpp
+ src/T2DLL/T2RouteCEArray.h
+ src/T2DLL/T2RouteNavigator.cpp
+ src/T2DLL/T2RouteNavigator.h
+ src/T2DLL/T2RoutingTable.cpp
+ src/T2DLL/T2RoutingTable.h
+ src/T2DLL/T2SantaClaus.cpp
+ src/T2DLL/T2SantaClaus.h
+ src/T2DLL/T2SearchDialog.cpp
+ src/T2DLL/T2SearchDialog.h
+ src/T2DLL/T2SettingDialog.cpp
+ src/T2DLL/T2SettingDialog.h
+ src/T2DLL/T2Settlement.cpp
+ src/T2DLL/T2Settlement.h
+ src/T2DLL/T2SilhouetteDef.cpp
+ src/T2DLL/T2SilhouetteDef.h
+ src/T2DLL/T2SilhouettePane.cpp
+ src/T2DLL/T2SilhouettePane.h
+ src/T2DLL/T2SoundPlayer.cpp
+ src/T2DLL/T2SoundPlayer.h
+ src/T2DLL/T2Sprite.cpp
+ src/T2DLL/T2Sprite.h
+ src/T2DLL/T2SpriteObj.cpp
+ src/T2DLL/T2SpriteObj.h
+ src/T2DLL/T2StairModule.cpp
+ src/T2DLL/T2StairModule.h
+ src/T2DLL/T2StairModuleList.cpp
+ src/T2DLL/T2StairModuleList.h
+ src/T2DLL/T2StewardDialog.cpp
+ src/T2DLL/T2StewardDialog.h
+ src/T2DLL/T2StopInfoArray.cpp
+ src/T2DLL/T2StopInfoArray.h
+ src/T2DLL/T2SubPlugin.cpp
+ src/T2DLL/T2SubPlugin.h
+ src/T2DLL/T2TemplatePlugin.cpp
+ src/T2DLL/T2TemplatePlugin.h
+ src/T2DLL/T2TemplatePluginDB.cpp
+ src/T2DLL/T2TemplatePluginDB.h
+ src/T2DLL/T2TemplatePluginList.cpp
+ src/T2DLL/T2TemplatePluginList.h
+ src/T2DLL/T2TempPluginComparator.cpp
+ src/T2DLL/T2TempPluginComparator.h
+ src/T2DLL/T2Tenant.cpp
+ src/T2DLL/T2Tenant.h
+ src/T2DLL/T2TenantArray.cpp
+ src/T2DLL/T2TenantArray.h
+ src/T2DLL/T2TenantArrayList.cpp
+ src/T2DLL/T2TenantArrayList.h
+ src/T2DLL/T2TenantCEArray.cpp
+ src/T2DLL/T2TenantCEArray.h
+ src/T2DLL/T2TenantDef.cpp
+ src/T2DLL/T2TenantDef.h
+ src/T2DLL/T2TenantInfoDialog.cpp
+ src/T2DLL/T2TenantInfoDialog.h
+ src/T2DLL/T2TenantMemberDef.cpp
+ src/T2DLL/T2TenantMemberDef.h
+ src/T2DLL/T2TenantMemberTableDef.cpp
+ src/T2DLL/T2TenantMemberTableDef.h
+ src/T2DLL/T2TenantPlugin.cpp
+ src/T2DLL/T2TenantPlugin.h
+ src/T2DLL/T2Terrorist.cpp
+ src/T2DLL/T2Terrorist.h
+ src/T2DLL/T2ToolDef.cpp
+ src/T2DLL/T2ToolDef.h
+ src/T2DLL/T2ToolDefList.cpp
+ src/T2DLL/T2ToolDefList.h
+ src/T2DLL/T2ToolHelpWnd.cpp
+ src/T2DLL/T2ToolHelpWnd.h
+ src/T2DLL/T2ToolPlugin.cpp
+ src/T2DLL/T2ToolPlugin.h
+ src/T2DLL/T2ToolWindow.cpp
+ src/T2DLL/T2ToolWindow.h
+ src/T2DLL/T2TowerEvent.cpp
+ src/T2DLL/T2TowerEvent.h
+ src/T2DLL/T2TowerMessage.cpp
+ src/T2DLL/T2TowerMessage.h
+ src/T2DLL/T2TowerVision.cpp
+ src/T2DLL/T2TowerVision.h
+ src/T2DLL/T2TrafficInfo.cpp
+ src/T2DLL/T2TrafficInfo.h
+ src/T2DLL/T2Transport.cpp
+ src/T2DLL/T2Transport.h
+ src/T2DLL/T2TreasureDialog.cpp
+ src/T2DLL/T2TreasureDialog.h
+ src/T2DLL/T2TreasurePane.cpp
+ src/T2DLL/T2TreasurePane.h
+ src/T2DLL/T2UnitInfo.cpp
+ src/T2DLL/T2UnitInfo.h
+ src/T2DLL/T2VerticalTable.cpp
+ src/T2DLL/T2VerticalTable.h
+ src/T2DLL/T2VisitVIP.cpp
+ src/T2DLL/T2VisitVIP.h
+ src/T2DLL/T2WeatherFilter.cpp
+ src/T2DLL/T2WeatherFilter.h
+ src/T2DLL/T2WordDef.cpp
+ src/T2DLL/T2WordDef.h
+ src/T2DLL/T2WordDefArray.cpp
+ src/T2DLL/T2WordDefArray.h
+ src/T2DLL/T2WorldDef.cpp
+ src/T2DLL/T2WorldDef.h
+ src/T2DLL/T2WorldPlugin.cpp
+ src/T2DLL/T2WorldPlugin.h
+ src/T2DLL/T2XEvent.cpp
+ src/T2DLL/T2XEvent.h
+ src/T2DLL/UPoint.cpp
+ src/T2DLL/UPoint.h
+ src/T2DLL/URect.cpp
+ src/T2DLL/URect.h
+ src/T2DLL/UT2BkgndInfo.cpp
+ src/T2DLL/UT2BkgndInfo.h
+ src/T2DLL/UT2Coordinate.cpp
+ src/T2DLL/UT2Coordinate.h
+ src/T2DLL/UT2Utils.cpp
+ src/T2DLL/UT2Utils.h
+ src/T2DLL/Wave.cpp
+ src/T2DLL/Wave.h
+ src/common.h
+ src/CT2App.h
+ src/T2TowerDoc.h
+ src/T2TowerMainView.h
+ src/T2DLL/T2NameComparator.h
+ src/T2DLL/T2NameComparator.cpp
+ src/T2DLL/T2ToolCallback.h
+ src/T2DLL/T2OptionPlugin.h
+ src/T2DLL/T2SeasonParamDef.cpp
+ src/T2DLL/T2SeasonParamDef.h
+ src/T2DLL/T2SerialDialog.cpp
+ src/T2DLL/T2SerialDialog.h
+ src/T2DLL/WalkerDlg.cpp
+ src/T2DLL/WalkerDlg.h
+ src/T2DLL/SoundDlg.cpp
+ src/T2DLL/SoundDlg.h
+ src/T2DLL/SpeedDlg.cpp
+ src/T2DLL/SpeedDlg.h
+ src/256CheckDialog.h
+ src/256CheckDialog.cpp
+ src/DbgEquipInfo.h
+ src/DbgEquipInfo.cpp
+ src/DbgEventList.h
+ src/DbgEventList.cpp
+ src/DbgIPS.h
+ src/DbgIPS.cpp
+ src/DbgPeopleView.h
+ src/DbgPeopleView.cpp
+ src/DbgStepRun.h
+ src/DbgStepRun.cpp
+ src/T2.h
+ src/T2.cpp
+ src/T2CtrlPalette.h
+ src/T2CtrlPalette.cpp
+ src/T2FilePreview.h
+ src/T2FilePreview.cpp
+ src/T2GraphWindow.h
+ src/T2GraphWindow.cpp
+ src/T2MainWindow.h
+ src/T2MainWindow.cpp
+ src/T2MsgWindow.h
+ src/T2MsgWindow.cpp
+ src/T2MWControl.h
+ src/T2MWControl.cpp
+ src/T2NewDlg.h
+ src/T2NewDlg.cpp
+ src/T2NewDlgTmp.h
+ src/T2NewDlgTmp.cpp
+ src/T2OpenFileDialog.h
+ src/T2OpenFileDialog.cpp
+ src/T2OpenningWindow.h
+ src/T2OpenningWindow.cpp
+ src/T2OpenSelectDlg.h
+ src/T2OpenSelectDlg.cpp
+ src/T2PoolView.h
+ src/T2PoolView.cpp
+ src/T2SysInfoDlg.h
+ src/T2SysInfoDlg.cpp
+ src/T2WorldSelectDlg.h
+ src/T2WorldSelectDlg.cpp
+ src/T2DLL/TenantSearchDlg.cpp
+ src/T2DLL/TenantSearchDlg.h
+ src/T2DLL/PeopleSearchDlg.cpp
+ src/T2DLL/PeopleSearchDlg.h
+ src/T2DLL/MoverSearchDlg.cpp
+ src/T2DLL/MoverSearchDlg.h
+ src/T2DLL/T2DlgItemArrows.cpp
+ src/T2DLL/T2DlgItemArrows.h
+ src/T2DLL/T2ColdTableDef.cpp
+ src/T2DLL/T2ColdTableDef.h
+ src/T2DLL/CEditWFocus.cpp
+ src/T2DLL/CEditWFocus.h
+ src/T2DLL/T2EventDialog.cpp
+ src/T2DLL/T2EventDialog.h
+ src/T2DLL/T2MetroRailway.cpp
+ src/T2DLL/T2MetroRailway.h
+ src/T2DLL/T2DlgItemIRepeater.cpp
+ src/T2DLL/T2DlgItemIRepeater.h
+ src/T2DLL/T2DlgItemMerchandiseField.cpp
+ src/T2DLL/T2DlgItemMerchandiseField.h
+ src/T2DLL/T2DlgItemRadioButton.cpp
+ src/T2DLL/T2DlgItemRadioButton.h
+ src/T2DLL/T2DlgItemRadioText.cpp
+ src/T2DLL/T2DlgItemRadioText.h
+)